Skip to main content
CVE-2024-47076VulnerabilityPublished Updated

Red Hat Security Advisory: cups-filters security update

Affects Red Hat cups-filtersSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-47076· High 8.6

Public exploit available (Metasploit) · 79% EPSS · CVSS 8.6 High : upgrade Red Hat cups-filters to 8.6.3 or 7.9.3 as a priority.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
79.8% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.6.3, 7.9.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Red Hat cups-filters to 8.6.3 or 7.9.3.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=7.0.0 <7.9.3
  • >=8.6.0 <8.6.3
Fixed in
  • 7.9.3
  • 8.6.3

AI-suggested

An official security update is available from Red Hat that addresses all identified vulnerabilities in cups-filters and cups-browsed. Users should apply the update promptly to remediate these issues. Additionally, the cups-browsed component is now provided as a separate sub-package, allowing users to uninstall it entirely if they do not require its functionality, thereby eliminating the associated generic network risk. For detailed update instructions and further information, refer to the Red Hat advisory at https://access.redhat.com/errata/RHSA-2024:7553 and https://access.redhat.com/articles/11258.

Description

Multiple security vulnerabilities have been identified and fixed in the cups-filters package used in Red Hat Enterprise Linux. These include denial-of-service via infinite loops, malformed PNG causing filter process aborts, input sanitization issues leading to potential remote command injection, and risks related to cups-browsed auto-creating print queues from untrusted network data. The update separates cups-browsed into its own sub-package to allow removal and reduce exposure to generic network-based risks. These issues affect various versions of Red Hat Enterprise Linux and related distributions.

References

Community reviews

Loading reviews…