Red Hat Security Advisory: cups security update
Affects Red Hat cupsSource GCVE Database
Public exploit available (Metasploit) · 63% EPSS · CVSS 8.6 High : upgrade the Red Hat redhat/cups package to 8.10 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 63.6% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Red Hat redhat/cups package to 8.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/cupspkg:rpm/redhat/cupsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat has released official security updates that fix this vulnerability. Users should apply the security update for CUPS as provided in Red Hat Advisory RHSA-2025:0083. Detailed instructions for applying the update are available in Red Hat's knowledge base article (https://access.redhat.com/articles/11258). No additional mitigation steps are indicated by the vendor.
Description
A low severity vulnerability (CVE-2024-47175) exists in the Common UNIX Printing System (CUPS) libppd component used in Red Hat Enterprise Linux 8 prior to version 8.10. The flaw allows remote command injection via attacker-controlled data in a PPD file. Red Hat has released an official security update to address this issue. Users of affected versions are advised to apply the provided patches to mitigate the vulnerability.
References
- access.redhat.com/errata/RHSA-2025:0083 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- access.redhat.com/security/vulnerabilities/RHSB-2024-002 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2314256 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_0083.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2024:9470 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_9470.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2024_9470.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2024-November/000555.html (opens in a new tab)
- suse.com/security/cve/CVE-2024-47175/ (opens in a new tab)