Skip to main content
CVE-2025-58060VulnerabilityPublished Updated

Red Hat Security Advisory: cups security update

Affects Red Hat cupsSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-58060· High 8.0

Not known to be exploited · CVSS 8.0 High : upgrade Red Hat cups to 9.9.0 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.9.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Red Hat cups to 9.9.0.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=9.0.0 <9.9.0
  • Red Hat
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Linux AppStream (v. 9)
  • Red Hat Enterprise Linux BaseOS (v. 9)
  • aarch64
Fixed in
  • 9.9.0

AI-suggested

A security update is available in CUPS version 2.4.16 that addresses these vulnerabilities. Red Hat has released updated packages for affected Red Hat Enterprise Linux 9 versions. Users should apply these official patches promptly. Before applying this update, ensure all previously released errata relevant to the system have been applied. Refer to the Red Hat advisory RHSA-2025:15700 and the linked documentation for detailed update instructions.

Description

Multiple critical security vulnerabilities were fixed in CUPS version 2.4.16, including local denial-of-service, slow client communication causing potential DoS, unsafe deserialization leading to null pointer dereference, and an authentication bypass via AuthType Negotiate. These issues affect various SUSE and Red Hat Enterprise Linux 9 versions. The update addresses these critical flaws and other bugs. Red Hat has issued an important security advisory with updated packages to remediate these vulnerabilities.

References

Community reviews

Loading reviews…