Red Hat Security Advisory: cups security update
Affects Red Hat cupsSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.0 High : upgrade Red Hat cups to 9.0.4 soon.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Red Hat cups to 9.0.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Red Hat Product Security Red Hat | Affected
| Fixed in
|
AI-suggested
Red Hat has released an important security update for CUPS in Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions to address these vulnerabilities. Users should apply the update to version 9.0.4 or later as detailed in the Red Hat advisory (https://access.redhat.com/articles/11258). No additional mitigation steps are indicated beyond applying the official update.
Description
Two security vulnerabilities have been identified in the Common UNIX Printing System (CUPS) used by Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions. The first vulnerability is an authentication bypass in CUPS authorization handling (CVE-2025-58060). The second vulnerability is a null pointer dereference in the CUPS ipp_read_io() function that can lead to a remote denial of service (CVE-2025-58364). Red Hat has issued an important security advisory with updates to address these issues.
References
- access.redhat.com/errata/RHSA-2025:16590 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2392595 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2393078 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_16590.json (opens in a new tab)