Skip to main content
CVE-2025-58060VulnerabilityPublished Updated

Red Hat Security Advisory: cups security update

Affects Red Hat cupsSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-58060· High 8.0

Not known to be exploited · CVSS 8.0 High : upgrade Red Hat cups to 10.2.0 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Red Hat cups to 10.2.0.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=10.0 <10.2.0
Fixed in
  • 10.2.0

AI-suggested

Red Hat has released updated CUPS packages for Red Hat Enterprise Linux 10 to address these vulnerabilities. Users should apply the security update RHSA-2025:15701 and ensure all previously released errata relevant to their system are applied before updating. Detailed update instructions are available from Red Hat's official documentation. No indication was given that no action is required; therefore, applying the official patch is the recommended mitigation.

Description

Two security vulnerabilities have been identified in the Common UNIX Printing System (CUPS) used in Red Hat Enterprise Linux 10. These include a null pointer dereference in the ipp_read_io() function that can cause a remote denial of service (CVE-2025-58364) and an authentication bypass in CUPS authorization handling (CVE-2025-58060). Red Hat has issued an important security advisory with updates to address these issues.

References

Community reviews

Loading reviews…