Skip to main content
CVE-2025-58060VulnerabilityPublished Updated

Red Hat Security Advisory: cups security update

Affects Red Hat cupsSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-58060· High 8.0

Not known to be exploited · CVSS 8.0 High : upgrade Red Hat cups to 9.2.4 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Red Hat cups to 9.2.4.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=9.2 <9.2.4
Fixed in
  • 9.2.4

AI-suggested

Red Hat has released an important security update that addresses these vulnerabilities. Users of Red Hat Enterprise Linux 9.2 should apply the update to versions >=9.2 and <9.2.4 as soon as possible. For detailed update instructions, refer to the Red Hat advisory at https://access.redhat.com/articles/11258. No additional mitigations are indicated by the vendor advisory.

Description

Two security vulnerabilities have been identified in the Common UNIX Printing System (CUPS) on Red Hat Enterprise Linux 9.2. These include an authentication bypass in CUPS authorization handling (CVE-2025-58060) and a null pointer dereference in the CUPS ipp_read_io() function that can lead to a remote denial of service (CVE-2025-58364). Red Hat has released an important security update addressing these issues for affected versions of Red Hat Enterprise Linux 9.2.

References

Community reviews

Loading reviews…