SUSE · security update for dotnet6.0
Affects SUSESource GCVE Database
Not known to be exploited : upgrade to 6.0.132 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 2.7% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.0.132
Exploitation evidence
Disclosed: evidence found.
CVE published 9 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade redhat/dotnet6.0 to 6.0.132.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/dotnet6.0pkg:rpm/redhat/dotnet6.0Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied. Users should upgrade to .NET SDK 6.0.132 and Runtime 6.0.32 or later versions as provided by their Linux distribution vendor (Red Hat or SUSE). Follow vendor-specific update instructions, such as those in the Red Hat advisory RHSA-2024:4438. No additional mitigation steps are indicated by the vendor advisory.
Description
.NET 6.0 versions prior to SDK 6.0.132 and Runtime 6.0.32 contain a vulnerability that allows denial of service (DoS) when parsing X.509 content and Object Identifiers. This issue is tracked as CVE-2024-38095. Red Hat and SUSE have released security updates addressing this vulnerability in their respective .NET 6.0 packages for Red Hat Enterprise Linux 8 and related distributions. The vulnerability is rated as moderate severity by Red Hat Product Security. No CVSS score is provided in the advisory. The fix is available and should be applied to mitigate the issue.
References
- access.redhat.com/errata/RHSA-2024:4438 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2295323 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_4438.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2024_4439.json (opens in a new tab)
- suse.com/security/cve/CVE-2024-38095/ (opens in a new tab)