Skip to main content
CVE-2024-23184VulnerabilityPublished Updated

SUSE dovecot · security update for dovecot

Affects SUSE dovecotSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-23184· Medium 5.0

Not known to be exploited · CVSS 5.0 Medium : upgrade the Red Hat redhat/dovecot package to 9.4 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
5.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/dovecot package to 9.4.

Affected software

ProductAffectedFixed in
Red Hatredhat/dovecotpkg:rpm/redhat/dovecotOther threatsAffected
  • >=9.0.0 <9.4
  • 9.4 <=9.8
Fixed in
  • 9.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available from Red Hat. Users should apply the update as described in the Red Hat advisory RHSA-2024:6529 to remediate these issues. No additional mitigation steps are indicated beyond applying the official patch.

Description

Two vulnerabilities in Dovecot, an IMAP and POP3 server, can lead to denial of service or resource exhaustion. CVE-2024-23184 allows denial of service by using a large number of address headers. CVE-2024-23185 causes resource exhaustion due to very large headers during message parsing. These issues affect Red Hat Enterprise Linux 9 and related variants. A security update addressing these vulnerabilities is available from Red Hat.

References

Community reviews

Loading reviews…