Skip to main content
CVE-2026-77219VulnerabilityPublished Updated

Red Hat Security Advisory: emacs security update

Affects Red Hat emacsSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-77219· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade Red Hat Emacs to 31.0.91 when convenient.

Data as of 31 Oct 2026, 10:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 31.0.91
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Emacs to 31.0.91.

Affected software

ProductAffectedFixed in
GNUEmacsAffected
  • <31.0.91
Fixed in–
GitHubEmacspkg:github/EmacsOther threatsAffected
  • <31.0.91
Fixed in
  • 31.0.91

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated Emacs packages that address these vulnerabilities. Users of Red Hat Enterprise Linux 8 should apply the security update as detailed in Red Hat's advisory and update to the fixed package versions (e.g., emacs-26.1-15.el8_10.2). No alternative mitigations or workarounds are specified. Applying the official update fully mitigates these issues.

Description

Two security vulnerabilities have been identified in GNU Emacs as distributed by Red Hat Enterprise Linux 8. The first is a heap over-read vulnerability that can lead to information disclosure when processing crafted images (CVE-2026-77219). The second is a local shell command injection vulnerability via the user field in Emacs TRAMP mode (CVE-2026-79992). Red Hat has issued an important security update addressing these issues for multiple architectures of Red Hat Enterprise Linux 8.

References

Community reviews

Loading reviews…