Skip to main content
CVE-2025-66418VulnerabilityPublished Updated

Red Hat Security Advisory: fence-agents security update

Affects Red Hat fence-agentsSource GCVE Database

0
Compare

Not known to be exploited : upgrade Red Hat fence-agents to 9.2.1 soon.

Data as of 30 Oct 2026, 20:52 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Red Hat fence-agents to 9.2.1.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=9.2 <9.2.1
Fixed in
  • 9.2.1

AI-suggested

Red Hat has released an official security update for fence-agents addressing CVE-2025-66418. Users should apply the update as per the instructions in the Red Hat advisory RHSA-2026:1330. The update is available for Red Hat Enterprise Linux 9.2 and its variants. Applying this update mitigates the vulnerability by fixing the unbounded decompression chain issue in urllib3. No additional mitigation steps are indicated by the vendor.

Description

A security update for the fence-agents packages in Red Hat Enterprise Linux addresses a vulnerability in urllib3 (CVE-2025-66418) involving an unbounded decompression chain that can lead to resource exhaustion. The fence-agents scripts manage remote power control for cluster devices, enabling forced restart and removal of failed or unreachable nodes. This vulnerability could impact cluster stability by exhausting system resources. The update is rated as Important by Red Hat Product Security and affects multiple Red Hat Enterprise Linux 9.2 variants, including High Availability and Resilient Storage editions.

References

Community reviews

Loading reviews…