Skip to main content
CVE-2025-4918VulnerabilityPublished Updated

SUSE · security update for firefox

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade the Red Hat redhat/firefox package to 9.6 soon.

Data as of 26 Oct 2026, 09:15 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
9.5% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/firefox package to 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/firefoxpkg:rpm/redhat/firefoxOther threatsAffected
  • >=9.0.0 <9.6
  • >=9.6 <=9.8
Fixed in
  • 9.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available from Red Hat to address these vulnerabilities. Users of affected Red Hat Enterprise Linux 9 versions should apply the Firefox update as detailed in the Red Hat advisory (RHSA-2025:8049) and the referenced update instructions. No additional mitigation steps are indicated by the vendor.

Description

Red Hat has issued an important security update for Mozilla Firefox addressing two out-of-bounds access vulnerabilities (CVE-2025-4918 and CVE-2025-4919) affecting Red Hat Enterprise Linux 9 and its extended support variants across multiple architectures. These vulnerabilities involve out-of-bounds access when resolving Promise objects and when optimizing linear sums. A security update is available to remediate these issues.

References

Community reviews

Loading reviews…