Skip to main content
Report · GCVE DatabaseAbout CVE-2024-29510Published Updated

SUSE · security update for ghostscript

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-29510· Medium 6.3

Not known to be exploited · public exploit available (Metasploit) · 27% EPSS · CVSS 6.3 Medium : upgrade to 9.4.0 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
27.9% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.4.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/ghostscript to 9.4.0.

Affected software

ProductAffectedFixed in
Red Hatredhat/ghostscriptpkg:rpm/redhat/ghostscriptOther threatsAffected
  • <9.4.0
  • >=9.4.0 <=9.8.0
Fixed in
  • 9.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available from Red Hat for Red Hat Enterprise Linux 9 and related variants that addresses these vulnerabilities. Users should apply the provided updates as described in the Red Hat advisory RHSA-2024:6197 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patch.

Description

Multiple security vulnerabilities have been identified in the Ghostscript suite used for rendering PostScript and PDF documents. These include a format string injection vulnerability that can lead to shell command execution bypassing SAFER restrictions (CVE-2024-29510), and two path traversal vulnerabilities that can lead to command execution or arbitrary file access (CVE-2024-33869 and CVE-2024-33870). Red Hat has issued a security advisory with updates for Red Hat Enterprise Linux 9 and related variants to address these issues. The update is rated as having a moderate security impact. Users of affected Red Hat Enterprise Linux 9 versions are advised to apply the provided updates to mitigate these vulnerabilities.

References

Community reviews

Loading reviews…