Skip to main content
CVE-2026-33818VulnerabilityPublished Updated

Red Hat Security Advisory: git-lfs security update

Affects Red Hat git-lfsSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-33818· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in Red Hat package updates : patch Red Hat asn1 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.27.0-rc.3, 1.26.6, 1.25.13
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade encoding/asn1 to 1.27.0-rc.3, 1.26.6 or 1.25.13.

Affected software

ProductAffectedFixed in
Go standard libraryencoding/asn1Affected
  • >=1.27.0-0 <1.27.0-rc.3
Fixed in
  • 1.27.0-rc.3
Go standard libraryencoding/asn1Affected
  • >=1.26.0-0 <1.26.6
Fixed in
  • 1.26.6
Go standard libraryencoding/asn1Affected
  • <1.25.13
Fixed in
  • 1.25.13
Goencoding/asn1pkg:golang/encoding/asn1Other threatsAffected
  • <1.25.13
  • >=1.26.0-0 <1.26.6
  • >=1.27.0-0 <1.27.0-rc.3
Fixed in
  • 1.25.13
  • 1.26.6
  • 1.27.0-rc.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated git-lfs packages that address these vulnerabilities. Users should apply the official Red Hat git-lfs updates for their respective Red Hat Enterprise Linux 10 variants as detailed in Red Hat advisory RHSA-2026:64788. No additional mitigation steps are indicated beyond applying the update.

Description

Red Hat issued a security advisory for git-lfs addressing multiple denial of service vulnerabilities in Go libraries used by git-lfs. The vulnerabilities include excessive recursion in ASN.1 unmarshalling, quadratic complexity in URL path resolution, and indefinite KeyUpdate messages in TLS. These issues could cause denial of service conditions. Red Hat has released updates for git-lfs on Red Hat Enterprise Linux 10 and related variants to fix these vulnerabilities.

References

Community reviews

Loading reviews…