Skip to main content
CVE-2024-34397VulnerabilityPublished Updated

Red Hat Security Advisory: glib2 security update

Affects Red Hat glib2Source GCVE Database

0
Compare
Authoritative record:CVE-2024-34397· Medium 5.2

Not known to be exploited · CVSS 5.2 Medium : upgrade the Debian debian/glib package to 2.80.1 or 2.78.5 when convenient.

Data as of 5 Nov 2026, 13:33 UTC

CVSS 3.1 base score
5.2Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.80.1, 2.78.5
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Debian debian/glib package to 2.80.1 or 2.78.5.

Affected software

ProductAffectedFixed in
Debiandebian/glibpkg:deb/debian/glibOther threatsAffected
  • <2.78.5
  • >=2.79.0 <2.80.1
Fixed in
  • 2.78.5
  • 2.80.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated glib2 packages to address this vulnerability. Users of affected Red Hat Enterprise Linux 9 versions should apply the security update as detailed in Red Hat advisory RHSA-2024:6464. The vendor provides instructions for applying the update at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official update.

Description

A moderate severity security vulnerability (CVE-2024-34397) affecting the glib2 library in Red Hat Enterprise Linux 9 has been addressed. The issue involves signal subscription vulnerabilities in the glib2 library, which provides core application building blocks for C libraries and applications, including the GNOME object system and utility functions. Red Hat has released an update to fix this vulnerability in multiple Red Hat Enterprise Linux 9 variants and architectures.

References

Community reviews

Loading reviews…