Skip to main content
CVE-2024-34397VulnerabilityPublished Updated

Red Hat Security Advisory: glib2 security update

Affects Red Hat glib2Source GCVE Database

0
Compare
Authoritative record:CVE-2024-34397· Medium 5.2

Not known to be exploited · CVSS 5.2 Medium : upgrade the Debian debian/glib package to 2.80.1 or 2.78.5 when convenient.

Data as of 5 Nov 2026, 13:33 UTC

CVSS 3.1 base score
5.2Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.80.1, 2.78.5
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Debian debian/glib package to 2.80.1 or 2.78.5.

Affected software

ProductAffectedFixed in
Debiandebian/glibpkg:deb/debian/glibOther threatsAffected
  • <2.78.5
  • >=2.79.0 <2.80.1
Fixed in
  • 2.78.5
  • 2.80.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for glib2 is available from Red Hat for affected Red Hat Enterprise Linux 9.2 and related products. Users should apply the updated packages (glib2-2.68.4-7.el9_2) as provided in the Red Hat advisory RHSA-2025:10780. No additional mitigation steps are indicated beyond applying the official patch.

Description

A security update for glib2 addresses signal subscription vulnerabilities identified as CVE-2024-34397. GLib is a core library used in C applications, including GNOME, providing essential functions and object systems. The vulnerability has been rated with moderate severity by Red Hat. The update is available for Red Hat Enterprise Linux 9.2 and related variants. No CVSS score is provided in the advisory. The update fixes the issue by patching the affected glib2 packages.

References

Community reviews

Loading reviews…