Skip to main content
CVE-2025-0395VulnerabilityPublished Updated

Red Hat Security Advisory: glibc security update

Affects Red Hat glibcSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade the Red Hat redhat/glibc package to 9.8 or 9.6 soon.

Data as of 26 Oct 2026, 11:42 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/glibc package to 9.8 or 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/glibcpkg:rpm/redhat/glibcOther threatsAffected
  • <9.6
  • <9.8
  • >=9.8
Fixed in
  • 9.6
  • 9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available from Red Hat that addresses these vulnerabilities. Users of affected Red Hat Enterprise Linux versions should apply the update as per Red Hat's advisory instructions at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official update.

Description

Multiple security vulnerabilities have been identified and fixed in the GNU C Library (glibc), including a buffer overflow in the assert() function (CVE-2025-0395), an integer overflow in the memalign suite (CVE-2026-0861), and issues with uninitialized memory that may cause process aborts (CVE-2026-0915 and CVE-2025-15281). These affect various versions of glibc used in Red Hat Enterprise Linux 8 and 9 distributions as well as SUSE. A security update is available that addresses these vulnerabilities.

References

Community reviews

Loading reviews…