Skip to main content
CVE-2024-0553VulnerabilityPublished Updated

Red Hat Security Advisory: gnutls security update

Affects Red Hat gnutlsSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-0553· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat gnutls to 3.8.3 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.6% chance of exploitation in 30 days – higher than 75% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.8.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gnutls to 3.8.3.

Affected software

ProductAffectedFixed in
gnutlsAffected
  • >=3.8.0 <3.8.3
Fixed in
  • 3.8.3
Debiandebian/gnutlspkg:deb/debian/gnutlsOther threatsAffected
  • =3.8.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated gnutls packages for Red Hat Enterprise Linux 9.2 Extended Update Support that address these vulnerabilities. Users should apply the security update as described in Red Hat advisory RHSA-2024:1082 to remediate these issues. Refer to https://access.redhat.com/articles/11258 for detailed update instructions. No additional mitigation steps are indicated by the vendor.

Description

A moderate severity vulnerability (CVE-2024-0553) affects the gnutls packages in Red Hat Enterprise Linux 8.6 Extended Update Support. This issue is an incomplete fix for a previous vulnerability (CVE-2023-5981) in the GNU Transport Layer Security (GnuTLS) library, which implements cryptographic protocols such as SSL, TLS, and DTLS. The vulnerability relates to CWE-203 (Information Exposure Through Discrepancy). Red Hat has released an updated package to address this issue.

References

Community reviews

Loading reviews…