Skip to main content
CVE-2026-111079VulnerabilityPublished

Red Hat Security Advisory: goose security update

Affects Red Hat gooseSource GCVE Database

0
Compare
Authoritative record:CVE-2026-111079· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade the Red Hat redhat/goose package to 1.45.0-2.el9_8 soon.

Data as of 6 Nov 2026, 11:23 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.4
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.45.0-2.el9_8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Red Hat redhat/goose package to 1.45.0-2.el9_8.

Affected software

ProductAffectedFixed in
Red Hatredhat/goosepkg:rpm/redhat/gooseOther threatsAffected
  • <1.45.0-2.el9_8
Fixed in
  • 1.45.0-2.el9_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated goose packages (version 1.45.0-2.el9_8) that fix this vulnerability. Users should apply this update to their Red Hat Enterprise Linux 9.8 systems after ensuring all previous errata are applied. Detailed update instructions are available from Red Hat's official documentation. No additional mitigation steps are indicated in the advisory.

Description

A security vulnerability identified as CVE-2026-111079 affects the goose package in Red Hat Enterprise Linux 9.8. The flaw involves a shell history and environment leak via terminal integration, potentially exposing sensitive information. Red Hat has released an update to address this issue in version 1.45.0-2.el9_8 of the goose package for multiple architectures. The update is rated as having an important security impact. No CVSS score is provided in the advisory.

References

Community reviews

Loading reviews…