Skip to main content
CVE-2025-67268VulnerabilityPublished Updated

Red Hat Security Advisory: gpsd-minimal security update

Affects Red Hat gpsd-minimalSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-67268· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade Red Hat gpsd to 10.0.1 as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ntpsec/gpsd to 10.0.1.

Affected software

ProductAffectedFixed in
GitHubntpsec/gpsdpkg:github/ntpsec/gpsdOther threatsAffected
  • 10.0 <10.0.1
Fixed in
  • 10.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated gpsd-minimal packages for Red Hat Enterprise Linux 9 and related variants that fix these vulnerabilities. Users should apply the security update as described in Red Hat advisory RHSA-2026:0771 and the update instructions at https://access.redhat.com/articles/11258. No additional mitigations are specified by the vendor. Patch status is confirmed as fixed in the updated packages.

Description

Red Hat has issued a security advisory for gpsd-minimal addressing two vulnerabilities: a denial of service caused by malformed NAVCOM packet parsing (CVE-2025-67269) and arbitrary code execution via a heap-based out-of-bounds write in NMEA2000 packet handling (CVE-2025-67268). These issues affect gpsd, a daemon that provides GPS sensor data over TCP port 2947. The advisory covers Red Hat Enterprise Linux 9 and related variants. The update is rated as Important by Red Hat Product Security. A fix is available in updated gpsd-minimal packages for affected Red Hat Enterprise Linux 9 versions.

References

Community reviews

Loading reviews…