Skip to main content
CVE-2024-47538VulnerabilityPublished Updated

Red Hat Security Advisory: gstreamer1-plugins-base security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 8.4.1 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/gstreamer1-plugins-base to 8.4.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/gstreamer1-plugins-basepkg:rpm/redhat/gstreamer1-plugins-baseOther threatsAffected
  • >=8.4 <8.4.1
Fixed in
  • 8.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated gstreamer1-plugins-base packages for Red Hat Enterprise Linux 8.4 variants that fix these vulnerabilities. Users should apply the security update as described in Red Hat advisory RHSA-2024:11143 and the referenced article https://access.redhat.com/articles/11258. Since this is an on-premises product, remediation requires manual update by system administrators.

Description

Multiple security vulnerabilities have been identified in the gstreamer1-plugins-base package used in Red Hat Enterprise Linux 8.4. These include stack-buffer overflows in vorbis_handle_identification_packet and gst_opus_dec_parse_header, as well as an out-of-bounds write in the Ogg demuxer. Red Hat has issued an important security advisory with updates to address these issues.

References

Community reviews

Loading reviews…