Skip to main content
CVE-2024-6655VulnerabilityPublished Updated

SUSE gtk3 · security update for gtk3

Affects SUSE gtk3Source GCVE Database

0
Authoritative record:CVE-2024-6655· High 7.0

Not known to be exploited · CVSS 7.0 High : upgrade the Red Hat redhat/gtk3 package to 9.5.0 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.0
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/gtk3 package to 9.5.0.

Affected software

ProductAffectedFixed in
Red Hatredhat/gtk3pkg:rpm/redhat/gtk3Other threatsAffected
  • <9.5.0
Fixed in
  • 9.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available from Red Hat to address this vulnerability. Users should apply the security update for gtk3 as provided in Red Hat Enterprise Linux 9 and related products. Follow the instructions in the Red Hat advisory RHSA-2024:9184 and the update article at https://access.redhat.com/articles/11258. No additional mitigation steps are specified by the vendor.

Description

A moderate severity security vulnerability (CVE-2024-6655) affecting the GTK+ library version 3 (gtk3) has been addressed by Red Hat. The vulnerability involves library injection from the current working directory (CWD), which could allow loading of malicious code. Red Hat has released an official update for Red Hat Enterprise Linux 9 and related products to fix this issue. Users are advised to apply the update following Red Hat's guidance to mitigate the risk.

References

Community reviews

Loading reviews…