Skip to main content
CVE-2024-38473VulnerabilityPublished Updated

SUSE · security update for httpd

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · public detection template (Nuclei) · 25% EPSS · fixed in 9.8 : patch SUSE soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
25.8% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6, 9.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jul 2024

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/httpd to 9.8, 9.6 or 9.4.

Affected software

ProductAffectedFixed in
Red Hatredhat/httpdpkg:rpm/redhat/httpdOther threatsAffected
  • >=9.0 <9.4
  • >=9.4 <9.6
  • >=9.6 <9.8
Fixed in
  • 9.4
  • 9.6
  • 9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated httpd packages that address these vulnerabilities. Users should apply the security update as detailed in the Red Hat advisory RHSA-2024:4726 to remediate these issues. For detailed update instructions, refer to https://access.redhat.com/articles/11258. Since a patch is available, applying the official update is the recommended mitigation.

Description

Red Hat has released an important security update for the Apache HTTP Server (httpd) packages addressing multiple vulnerabilities in the mod_rewrite and mod_proxy modules. The issues include improper escaping of output, substitution encoding problems, null pointer dereference, potential server-side request forgery (SSRF), and encoding problems. These vulnerabilities affect Red Hat Enterprise Linux 9 and its Extended Update Support and Extended Life Cycle versions across multiple architectures. Updated packages are available to remediate these issues.

References

Community reviews

Loading reviews…