CVE-2024-38476: Apache HTTP Server · Untrusted Functionality Inclusion
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · 41% EPSS · CVSS 9.8 Critical · fixed in 2.4.60 : patch Apache HTTP Server as a priority.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 41.6% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.60
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Apacheapache/httpdpkg:rpm/apache/httpdOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade all Apache HTTP Server instances to version 2.4.60 or later to remediate CVE-2024-38476. In addition to patching, organizations should implement strict validation and sanitization of backend application responses, especially headers, to detect and block anomalous or suspicious content. Deploying Web Application Firewalls (WAFs) with updated rules to identify SSRF patterns and malicious header manipulations can provide an additional protective layer. Network segmentation should be enforced to limit backend application exposure and restrict server access to trusted sources only. Continuous monitoring and logging of HTTP server behavior and backend responses can help detect exploitation attempts early. Incident response plans should be updated to include this vulnerability, ensuring rapid containment and recovery. Finally, organizations should conduct regular security assessments and penetration tests focusing on SSRF and header injection vectors to proactively identify residual risks.
Description
Vulnerability in core of Apache HTTP Server 2.4.59 and earlier are vulnerably to information disclosure, SSRF or local script execution via backend applications whose response headers are malicious or exploitable. Users are recommended to upgrade to version 2.4.60, which fixes this issue.