Skip to main content
CVE-2024-38476VulnerabilityPublished Updated

Red Hat Security Advisory: httpd:2.4 security update

Affects Red Hat httpd:2.4Source GCVE Database

0
Compare
Authoritative record:CVE-2024-38476· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical.

Data as of 5 Nov 2026, 17:20 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.19.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <=2.4.59
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for the httpd:2.4 package in Red Hat Enterprise Linux 8.8 Extended Update Support and related variants. Users should apply this update promptly following Red Hat's published guidance at https://access.redhat.com/articles/11258 to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A security update for the Apache HTTP Server (httpd) 2.4 package addresses a vulnerability identified as CVE-2024-38476. This issue involves security problems caused by backend applications whose response headers may be malicious or exploitable. The update is rated as important by Red Hat Product Security and affects Red Hat Enterprise Linux 8.8 Extended Update Support and related variants. The advisory provides a fix to mitigate the vulnerability.

References

Community reviews

Loading reviews…