Skip to main content
CVE-2025-55154VulnerabilityPublished Updated

SUSE · GraphicsMagick-1.3.48-2.1 on GA media

Affects SUSESource GCVE Database

0

Not known to be exploited : upgrade to 6.9.10.68-8.el7_9 or 1.3.48-2.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · CVSS not yet scored by NVD

EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.9.10.68-8.el7_9, 1.3.48-2.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade SUSE to 6.9.10.68-8.el7_9 or 1.3.48-2.1.

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=1.3.48 <1.3.48-2.1
  • >=6.9.10.68 <6.9.10.68-8.el7_9
Fixed in
  • 1.3.48-2.1
  • 6.9.10.68-8.el7_9

AI-suggested

Red Hat and SUSE have released updated packages that fix this vulnerability. Users should apply the official security updates for ImageMagick (e.g., ImageMagick-6.9.10.68-8.el7_9 for Red Hat Enterprise Linux 7) or GraphicsMagick-1.3.48-2.1 on openSUSE Tumbleweed. Refer to the vendor advisories and update instructions at https://access.redhat.com/articles/11258. No additional mitigation is required beyond applying the official patches.

Description

CVE-2025-55154 is an integer overflow vulnerability in ImageMagick affecting MNG magnification. It is addressed in the GraphicsMagick-1.3.48-2.1 package on openSUSE Tumbleweed and related Red Hat Enterprise Linux 7 Extended Lifecycle Support packages. The issue could lead to security risks if exploited. Red Hat has released an important security update fixing this vulnerability in ImageMagick 6.9.10.68-8.el7_9. No known exploits are reported in the wild. The vulnerability is rated medium severity.

References

Community reviews

Loading reviews…