Skip to main content
CVE-2025-48964VulnerabilityPublished Updated

SUSE · security update for iputils

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2025-48964· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium : upgrade the Red Hat redhat/iputils package to 9.4.5 when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.4.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/iputils package to 9.4.5.

Affected software

ProductAffectedFixed in
Red Hatredhat/iputilspkg:rpm/redhat/iputilsOther threatsAffected
  • =9.4
  • <9.4.5
Fixed in
  • 9.4.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied to affected systems. Red Hat provides updated iputils packages for Red Hat Enterprise Linux 9 and related variants. Users should follow the vendor's update instructions as detailed in the Red Hat advisory (RHSA-2025:17558). No additional mitigation steps are indicated beyond applying the official patch.

Description

An integer overflow vulnerability (CVE-2025-48964) has been identified in the iputils package, which provides basic network monitoring utilities including ping. This vulnerability affects multiple Red Hat Enterprise Linux 9 variants and SUSE Linux Enterprise versions. The issue has been rated as having moderate security impact. A security update addressing this vulnerability is available from Red Hat and SUSE.

References

Community reviews

Loading reviews…