Skip to main content
CVE-2024-21131VulnerabilityPublished Updated

SUSE · security update for java-17-openjdk

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 10.0 or 9.0 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.0, 9.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade SUSE to 10.0 or 9.0.

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=8.4 <9.0
  • >=9.0 <10.0
  • =1:17.0.12.0.7-2.el9.x86_64
Fixed in
  • 9.0
  • 10.0

AI-suggested

A security update for java-17-openjdk is available from Red Hat and SUSE. Users should apply the update promptly to remediate the vulnerabilities. After applying the update, all running OpenJDK Java instances must be restarted for the fixes to take effect. Refer to the vendor advisory at https://access.redhat.com/errata/RHSA-2024:4568 and https://access.redhat.com/articles/11258 for detailed update instructions.

Description

Multiple security vulnerabilities have been identified and fixed in the java-17-openjdk packages, which provide the OpenJDK 17 Java Runtime Environment and Software Development Kit. These include array index overflow, potential UTF8 size overflow, infinite loop due to excessive symbol length, pre-loop limit overflow, and out-of-bounds access in 2D image handling. The update addresses these issues to prevent potential security risks. The vulnerabilities affect various Red Hat Enterprise Linux and SUSE versions. A security update is available and should be applied, with a restart of all running OpenJDK Java instances required for the update to take effect.

References

Community reviews

Loading reviews…