Skip to main content
CVE-2024-21131VulnerabilityPublished Updated

SUSE · security update for java-1.8.0-openjdk

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=8.2 <=8.4
  • >=8.6 <=8.8
  • >=9.0 <=9.8
Fixed in–

AI-suggested

A security update is available from Red Hat and SUSE for the java-1.8.0-openjdk packages. Users should apply the update as per the vendor instructions in the Red Hat advisory RHSA-2024:4563 and corresponding SUSE advisories. After applying the update, all running OpenJDK Java instances must be restarted to ensure the fixes take effect.

Description

Multiple security vulnerabilities have been identified and fixed in the java-1.8.0-openjdk packages, which provide the OpenJDK 8 Java Runtime Environment and Software Development Kit. These include array index overflow, UTF8 size overflow, infinite loop due to excessive symbol length, pre-loop limit overflow, improper header validation causing increased loading time, and out-of-bounds access in 2D image handling. The vulnerabilities affect various Red Hat Enterprise Linux and SUSE versions. A security update is available and must be applied, followed by restarting all running OpenJDK Java instances for the fixes to take effect.

References

Community reviews

Loading reviews…