Skip to main content
CVE-2024-23337VulnerabilityPublished Updated

SUSE · security update for jq

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade SUSE to 9.6.0 when convenient.

Data as of 26 Oct 2026, 08:30 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade SUSE to 9.6.0.

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=9.0.0 <9.6.0
  • >=9.6.0 <=9.8.0
Fixed in
  • 9.6.0

AI-suggested

Red Hat has released updated jq packages that address these vulnerabilities. Users of affected Red Hat Enterprise Linux 9 and related CodeReady Linux Builder packages should apply the available security update as detailed in Red Hat advisory RHSA-2025:10585. For update instructions, refer to https://access.redhat.com/articles/11258. Since an official fix is available, applying the update is the recommended remediation.

Description

Two security vulnerabilities have been identified in the jq JSON processor used in Red Hat Enterprise Linux 9. These include a signed integer overflow (CVE-2024-23337) and a stack-buffer-overflow detected by AddressSanitizer (CVE-2025-48060). The vulnerabilities affect multiple architectures and variants of Red Hat Enterprise Linux 9 and related CodeReady Linux Builder packages. Red Hat has released an update to address these issues, which have been rated with moderate security impact. Users should apply the available update to remediate these vulnerabilities.

References

Community reviews

Loading reviews…