Skip to main content
CVE-2024-53141VulnerabilityPublished Updated

Red Hat Security Advisory: kernel security update

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited : upgrade Linux kernel to 8.4.305.157.1 soon.

Data as of 29 Oct 2026, 10:36 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.305.157.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Linux kernel to 8.4.305.157.1.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=8.4 <8.4.305.157.1
Fixed in
  • 8.4.305.157.1

AI-suggested

Red Hat has released an updated kernel package that addresses these vulnerabilities. Users of Red Hat Enterprise Linux 8.4 should apply the kernel update as provided in the advisory and reboot their systems to ensure the fixes take effect. Detailed update instructions are available at https://access.redhat.com/articles/11258. No additional mitigations are specified beyond applying the official update and rebooting.

Description

This Red Hat security advisory addresses two vulnerabilities in the Linux kernel packages for Red Hat Enterprise Linux 8.4. The first vulnerability (CVE-2024-53141) involves a missing range check in the netfilter ipset bitmap_ip_uadt component. The second vulnerability (CVE-2025-21756) concerns the vsock subsystem, where the binding is not maintained until socket destruction. The advisory rates the update as important and recommends applying the kernel update and rebooting the system to mitigate these issues.

References

Community reviews

Loading reviews…