Skip to main content
CVE-2024-42283VulnerabilityPublished Updated

SUSE · security update for kernel

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 9.8 or 9.6 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade redhat/kernel to 9.8 or 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/kernelpkg:rpm/redhat/kernelOther threatsAffected
  • =9
  • <9.6
  • >=9.6
  • <9.8
Fixed in
  • 9.6
  • 9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Updated kernel packages fixing these vulnerabilities have been released by Red Hat. Users should apply the security update as soon as possible and reboot their systems to ensure the fixes take effect. Refer to the Red Hat advisory RHSA-2024:9605 for detailed update instructions.

Description

Multiple moderate-severity vulnerabilities have been identified in the Linux kernel packages used by Red Hat Enterprise Linux 9. These include improper initialization of nexthop fields (CVE-2024-42283), a requirement for drivers to supply cache_invalidate_user operations (CVE-2024-46824), and a use-after-free vulnerability in the multipath TCP timer deletion function (CVE-2024-46858). Red Hat has released updated kernel packages to address these issues. A system reboot is required to apply the updates effectively.

References

Community reviews

Loading reviews…