Skip to main content
CVE-2025-49091VulnerabilityPublished Updated

CVE-2025-49091: KDE Konsole before 25.04.2 allows remote code execution in a certain scenario

Affects konsoleSource GCVE Database

0

Not known to be exploited · CVSS 8.2 Medium : upgrade to 7.9.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.9.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/konsole to 7.9.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/konsolepkg:rpm/redhat/konsoleOther threatsAffected
  • =7
  • <7.9.1
Fixed in
  • 7.9.1
Ubuntu:16.04:LTSkonsolepkg:deb/ubuntu/konsole?arch=source&distro=xenialOther threatsAffected
  • =4:15.08.2-0ubuntu2
  • =4:15.12.1-1ubuntu1
  • =4:15.12.3-0ubuntu1
Fixed in–
Ubuntu:18.04:LTSkonsolepkg:deb/ubuntu/konsole?arch=source&distro=bionicOther threatsAffected
  • =4:17.04.3-0ubuntu1
  • =4:17.08.3-0ubuntu1
  • =4:17.12.2-0ubuntu1
  • =4:17.12.3-0ubuntu1
  • =4:17.12.3-1ubuntu1
Fixed in–
Ubuntu:20.04:LTSkonsolepkg:deb/ubuntu/konsole?arch=source&distro=focalOther threatsAffected
  • =4:19.04.3-0ubuntu1
  • =4:19.08.2-0ubuntu1
  • =4:19.08.3-0ubuntu1
  • =4:19.12.0-0ubuntu1
  • =4:19.12.1-0ubuntu1
  • =4:19.12.2-0ubuntu1
  • =4:19.12.3-0ubuntu1
Fixed in–
Ubuntu:22.04:LTSkonsolepkg:deb/ubuntu/konsole?arch=source&distro=jammyOther threatsAffected
  • =4:21.08.1-1ubuntu1
  • =4:21.08.2-1
  • =4:21.08.3-0ubuntu1
  • =4:21.11.80-0ubuntu1
  • =4:21.11.90-0ubuntu2
  • =4:21.12.0-0ubuntu1
  • =4:21.12.0-0ubuntu2
  • =4:21.12.1-0ubuntu1
  • =4:21.12.2-0ubuntu1
  • =4:21.12.3-0ubuntu1
Fixed in–
Ubuntu:24.04:LTSkonsolepkg:deb/ubuntu/konsole?arch=source&distro=nobleOther threatsAffected
  • =4:23.08.1-0ubuntu1
  • =4:23.08.2-0ubuntu1
  • =4:23.08.3-0ubuntu1
  • =4:23.08.4-0ubuntu1
  • =4:23.08.4-0ubuntu2
  • =4:23.08.5-0ubuntu1
  • =4:23.08.5-0ubuntu2
  • =4:23.08.5-0ubuntu3
  • =4:23.08.5-0ubuntu4
Fixed in–
Ubuntu:25.10konsolepkg:deb/ubuntu/konsole?arch=source&distro=questingOther threatsAffected
  • =4:24.12.3-0ubuntu1
  • =4:25.04.0-0ubuntu1
  • =4:25.04.1-0ubuntu1
  • =4:25.04.2-0ubuntu1
  • =4:25.04.2-1ubuntu1
  • =4:25.04.3-0ubuntu1
  • =4:25.07.80-0ubuntu1
  • =4:25.07.90-0ubuntu1
  • =4:25.08.0-0ubuntu1
  • =4:25.08.1-0ubuntu1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available from Red Hat for their Extended Lifecycle Support 7 packages. Users should apply the official patches provided by their vendor to remediate this issue. Refer to the Red Hat advisory RHSA-2025:12346 for detailed update instructions. Since a fix is available, applying the update is the recommended mitigation. No additional workarounds or mitigations are indicated in the vendor advisory.

Description

KDE Konsole before 25.04.2 allows remote code execution in a certain scenario. It supports loading URLs from the scheme handlers such as a ssh:// or telnet:// or rlogin:// URL. This can be executed regardless of whether the ssh, telnet, or rlogin binary is available. In this mode, there is a code path where if that binary is not available, Konsole falls back to using /bin/bash for the given arguments (i.e., the URL) provided. This allows an attacker to execute arbitrary code.

Reports on CVE-2025-49091

References

Community reviews

Loading reviews…