Skip to main content
CVE-2024-32487VulnerabilityPublished Updated

SUSE · security update for less

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2024-32487· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade the Red Hat redhat/less package to 7.9.10 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.9.10
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/less package to 7.9.10.

Affected software

ProductAffectedFixed in
Red Hatredhat/lesspkg:rpm/redhat/lessOther threatsAffected
  • <7.9.10
Fixed in
  • 7.9.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official security update from Red Hat is available and should be applied promptly to remediate this vulnerability. The update addresses the OS command injection flaw in the 'less' utility. Users should follow Red Hat's guidance for applying the patch as detailed in their advisory (RHSA-2024:3669). No additional mitigation steps are indicated beyond applying the official fix.

Description

A security vulnerability (CVE-2024-32487) affecting the 'less' utility in Red Hat Enterprise Linux 7 has been identified. This vulnerability is an OS command injection flaw that could allow an attacker to execute arbitrary commands. Red Hat has released an important security update to address this issue. The update is available for multiple variants and architectures of Red Hat Enterprise Linux 7. Users are advised to apply the patch to remediate the vulnerability.

References

Community reviews

Loading reviews…