Skip to main content
CVE-2024-57970VulnerabilityPublished Updated

Red Hat Security Advisory: libarchive security update

Affects Red HatSource GCVE Database

0

Not known to be exploited : upgrade to 10.2.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade redhat/libarchive to 10.2.0.

Affected software

ProductAffectedFixed in
Red Hatredhat/libarchivepkg:rpm/redhat/libarchiveOther threatsAffected
  • =10.0
  • <10.2.0
Fixed in
  • 10.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update that fixes this vulnerability. Users should apply the libarchive update available for Red Hat Enterprise Linux 10 to remediate the issue. For detailed update instructions, refer to the Red Hat advisory at https://access.redhat.com/articles/11258. No additional mitigation is required beyond applying the official patch.

Description

A heap buffer over-read vulnerability (CVE-2024-57970) exists in the libarchive library's header_gnu_longlink function. Libarchive is widely used for creating and reading various archive formats and is included in utilities like bsdtar and language bindings such as python-libarchive. This vulnerability affects Red Hat Enterprise Linux 10 versions prior to 10.2.0. Red Hat has released a security update to address this issue.

References

Community reviews

Loading reviews…