Skip to main content
CVE-2024-5564VulnerabilityPublished Updated

Red Hat Security Advisory: libndp security update

Affects Red Hat libndpSource GCVE Database

0
Compare
Authoritative record:CVE-2024-5564· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade Red Hat libndp to 1.7-7 soon.

Data as of 5 Nov 2026, 14:51 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.18.1
Patch
Available – fixed in 1.7-7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade libndp to 1.7-7.

Affected software

ProductAffectedFixed in
libndpAffected
  • >=1.0 <1.7-7
Fixed in
  • 1.7-7
Red Hatredhat/libndppkg:rpm/redhat/libndpOther threatsAffected
  • =1.0
Fixed in–
GitHublibndppkg:github/libndpOther threatsAffected
  • >=1.0 <1.7-7
Fixed in
  • 1.7-7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libndp packages for Red Hat Enterprise Linux 8.4 variants that address this buffer overflow vulnerability. Users should apply the security update as detailed in Red Hat advisory RHSA-2024:4618 and the referenced article https://access.redhat.com/articles/11258. Applying this update remediates the vulnerability. No additional mitigation steps are specified by the vendor.

Description

A buffer overflow vulnerability exists in the libndp library used by NetworkManager for IPv6 Neighbor Discovery Protocol. The flaw is in the route information length field and is identified as CVE-2024-5564. Red Hat has issued an important security update addressing this issue for Red Hat Enterprise Linux 8.4 variants. The vulnerability has a high severity rating but no CVSS score is provided. No known exploits are reported in the wild.

References

Community reviews

Loading reviews…