Red Hat Security Advisory: libpng security update
Affects Red Hat libpngSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.1 High : upgrade Red Hat libpng to 1.6.51 soon.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.51
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pnggroup/libpng to 1.6.51.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubpnggroup/libpngpkg:github/pnggroup/libpngOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat has released updated libpng packages that address these vulnerabilities. Users of Red Hat Enterprise Linux 9 through 9.8 should apply the security update as described in the Red Hat advisory RHSA-2026:0238 and the referenced article https://access.redhat.com/articles/11258. Applying these official patches is the recommended remediation.
Description
Multiple security vulnerabilities have been identified in the libpng library used by Red Hat Enterprise Linux 9. These include buffer overflow and heap buffer overflow issues, as well as an out-of-bounds read in the png_image_read_composite function. Red Hat has issued an important security advisory with updates addressing these vulnerabilities. The affected versions include Red Hat Enterprise Linux 9 through 9.8 across various architectures. The advisory provides updated libpng packages to remediate these issues.
References
- access.redhat.com/errata/RHSA-2026:0238 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2416904 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2416907 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2418711 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_0238.json (opens in a new tab)