Skip to main content
CVE-2026-25646VulnerabilityPublished Updated

Red Hat Security Advisory: libpng15 security update

Affects Red Hat libpng15Source GCVE Database

0
Compare
Authoritative record:CVE-2026-25646· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade Red Hat libpng15 to 1.6.55 soon.

Data as of 30 Oct 2026, 21:21 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.55
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade libpng to 1.6.55.

Affected software

ProductAffectedFixed in
pnggrouplibpngAffected
  • <1.6.55
Fixed in
  • 1.6.55

AI-suggested

Red Hat has released an official security update for libpng15 in Red Hat Enterprise Linux 8.2 Advanced Update Support to address this vulnerability. Users should apply the update as detailed in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the issue. Since a fix is available, applying the update is the recommended mitigation.

Description

A heap buffer overflow vulnerability exists in the libpng15 package's png_set_quantize function. libpng15 is an older version of the libpng library used for manipulating PNG image files and should only be used if the current libpng version cannot be used. This vulnerability has been addressed in a security update by Red Hat for Red Hat Enterprise Linux 8.2 Advanced Update Support.

References

Community reviews

Loading reviews…