Skip to main content
CVE-2026-102556VulnerabilityPublished

Red Hat Security Advisory: libsoup security update

Affects Red Hat libsoupSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-102556· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade the Red Hat redhat/libsoup package to 9.4.0-8.el9_4.17 soon.

Data as of 2 Nov 2026, 04:29 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.18.6
Patch
Available – fixed in 9.4.0-8.el9_4.17
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade the Red Hat redhat/libsoup package to 9.4.0-8.el9_4.17.

Affected software

ProductAffectedFixed in
Red Hatredhat/libsouppkg:rpm/redhat/libsoupOther threatsAffected
  • >=9.4 <9.4.0-8.el9_4.17
Fixed in
  • 9.4.0-8.el9_4.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libsoup packages for Red Hat Enterprise Linux 9.4 and related variants that address these vulnerabilities. Users should apply the official Red Hat security updates as detailed in the advisory (RHSA-2026:93445) to remediate these issues. Patch status is confirmed with fixed versions available in Red Hat Enterprise Linux 9.4 updates.

Description

Multiple heap buffer overflow vulnerabilities have been identified in the libsoup HTTP client and server library for GNOME, affecting WebSocket handling and permessage-deflate buffer growth. These vulnerabilities can lead to memory corruption. Red Hat has issued security updates addressing these issues in Red Hat Enterprise Linux 9.4 variants.

References

Community reviews

Loading reviews…