Skip to main content
CVE-2025-32050VulnerabilityPublished Updated

Red Hat Security Advisory: libsoup security update

Affects Red Hat libsoupSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade the Red Hat redhat/libsoup package to 8.8.4 soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.8.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/libsoup package to 8.8.4.

Affected software

ProductAffectedFixed in
Red Hatredhat/libsouppkg:rpm/redhat/libsoupOther threatsAffected
  • <8.8.4
Fixed in
  • 8.8.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libsoup packages for Red Hat Enterprise Linux 8.8 Extended Update Support that address these vulnerabilities. Users should apply the security update as described in Red Hat advisory RHSA-2025:4568 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official update.

Description

Multiple security vulnerabilities have been identified in the libsoup HTTP client and server library for GNOME, affecting Red Hat Enterprise Linux 8.8 Extended Update Support. These include integer overflow, heap buffer overflows, out of bounds reads, double free, NULL pointer dereference, information disclosure, and memory leak issues. The vulnerabilities are rated with high severity by Red Hat Product Security. An update addressing these issues is available for affected Red Hat Enterprise Linux 8.8 Extended Update Support versions.

References

Community reviews

Loading reviews…