Skip to main content
CVE-2025-32906VulnerabilityPublished Updated

Red Hat Security Advisory: libsoup security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 8.4.4 soon.

Data as of 26 Oct 2026, 06:26 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade redhat/libsoup to 8.4.4.

Affected software

ProductAffectedFixed in
Red Hatredhat/libsouppkg:rpm/redhat/libsoupOther threatsAffected
  • >=8.4 <8.4.4
Fixed in
  • 8.4.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libsoup packages that address all listed vulnerabilities. Users of Red Hat Enterprise Linux 8.4 variants should apply the security update described in advisory RHSA-2025:4609 promptly. For detailed update instructions, refer to https://access.redhat.com/articles/11258. No additional mitigations are indicated in the advisory.

Description

Multiple vulnerabilities have been identified in the libsoup HTTP client and server library for GNOME, including out-of-bounds reads, double free, NULL pointer dereference, information disclosure, and memory leaks. These issues affect Red Hat Enterprise Linux 8.4 variants and are rated with an important security impact by Red Hat. The vulnerabilities could lead to crashes, memory corruption, or unintended information disclosure. Red Hat has released security updates addressing these issues.

References

Community reviews

Loading reviews…