Skip to main content
CVE-2025-2784VulnerabilityPublished Updated

Red Hat Security Advisory: libsoup security update

Affects Red Hat libsoupSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade the Red Hat redhat/libsoup package to 8.6.5 soon.

Data as of 26 Oct 2026, 09:15 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.6.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/libsoup package to 8.6.5.

Affected software

ProductAffectedFixed in
Red Hatredhat/libsouppkg:rpm/redhat/libsoupOther threatsAffected
  • =8.6
  • <8.6.5
Fixed in
  • 8.6.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libsoup packages for Red Hat Enterprise Linux 8.6 variants that address these vulnerabilities. Users should apply the security update as detailed in Red Hat advisory RHSA-2025:8482. For update instructions, refer to https://access.redhat.com/articles/11258. No additional mitigations are specified beyond applying the official update.

Description

The libsoup packages provide an HTTP client and server library for GNOME. Security Fix(es): * libsoup: Heap buffer over-read in `skip_insignificant_space` when sniffing content (CVE-2025-2784) * libsoup: Denial of Service attack to websocket server (CVE-2025-32049) * libsoup: OOB Read on libsoup through function "soup_multipart_new_from_message" in soup-multipart.c leads to crash or exit of process (CVE-2025-32914) * libsoup: Integer Underflow in soup_multipart_new_from_message() Leading to Denial of Service in libsoup (CVE-2025-4948) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…