Skip to main content
CVE-2024-4418VulnerabilityPublished Updated

Red Hat Security Advisory: libvirt security update

Affects Red Hat libvirtSource GCVE Database

0
Compare
Authoritative record:CVE-2024-4418· Medium 6.2

Not known to be exploited · CVSS 6.2 Medium : upgrade Red Hat libvirt to 10.4.0 when convenient.

Data as of 5 Nov 2026, 17:09 UTC

CVSS 3.1 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.16.2
Patch
Available – fixed in 10.4.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade libvirt to 10.4.0.

Affected software

ProductAffectedFixed in
libvirtAffected
  • <10.4.0
Fixed in
  • 10.4.0

AI-suggested

Red Hat has released updated libvirt packages for Red Hat Enterprise Linux 9.2 Extended Update Support and related variants that fix this vulnerability. Users should apply these official updates promptly to remediate the issue. Detailed update instructions are available in the Red Hat advisory and knowledge base article linked in the vendor advisory. No additional mitigation steps are indicated by Red Hat.

Description

A stack use-after-free vulnerability (CVE-2024-4418) was identified in the libvirt library's virNetClientIOEventLoop() function. Libvirt is a C API used for managing virtualization capabilities on Linux and other operating systems, including remote management tools. This vulnerability has been rated as having a moderate security impact by Red Hat. An update addressing this issue is available for Red Hat Enterprise Linux 9.2 Extended Update Support and related variants.

References

Community reviews

Loading reviews…