Skip to main content
CVE-2025-6021VulnerabilityPublished Updated

Red Hat Security Advisory: libxml2 security update

Affects Red Hat libxml2Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-6021· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat libxml2 to 2.14.4 soon.

Data as of 29 Oct 2026, 10:37 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.14.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libxml2 to 2.14.4.

Affected software

ProductAffectedFixed in
libxml2Affected
  • <2.14.4
Fixed in
  • 2.14.4

AI-suggested

Red Hat has released updated libxml2 packages for Red Hat Enterprise Linux 8.2 to address these vulnerabilities. Users should apply the security updates as detailed in the Red Hat advisory RHSA-2025:12237 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patches.

Description

Multiple security vulnerabilities have been identified in the libxml2 library used in Red Hat Enterprise Linux 8.2. These include out-of-bounds read, heap use-after-free, type confusion, and an integer overflow leading to a stack buffer overflow. These issues can lead to denial of service or memory corruption. Red Hat has issued a security advisory with updates to address these vulnerabilities.

References

Community reviews

Loading reviews…