Skip to main content
CVE-2024-55549VulnerabilityPublished Updated

Red Hat Security Advisory: libxslt security update

Affects Red Hat libxsltSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-55549· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade the Debian debian/libxslt package to 1.1.43 soon.

Data as of 5 Nov 2026, 14:32 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.17.8
Patch
Available – fixed in 1.1.43
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Debian debian/libxslt package to 1.1.43.

Affected software

ProductAffectedFixed in
Debiandebian/libxsltpkg:deb/debian/libxsltOther threatsAffected
  • <1.1.43
Fixed in
  • 1.1.43

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates for affected Red Hat Enterprise Linux 8.4 variants. Users should apply these updates promptly to remediate the vulnerabilities. For detailed update instructions, refer to Red Hat's advisory and article at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the provided patches.

Description

Two use-after-free vulnerabilities (CVE-2024-55549 and CVE-2025-24855) were discovered in the libxslt library used for XML transformations. These flaws could lead to memory corruption issues. Red Hat has issued security updates addressing these vulnerabilities in Red Hat Enterprise Linux 8.4 variants. The update is rated as having an Important security impact by Red Hat Product Security.

References

Community reviews

Loading reviews…