Skip to main content
CVE-2024-55549VulnerabilityPublished Updated

Red Hat Security Advisory: libxslt security update

Affects Red Hat libxsltSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-55549· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade the Debian debian/libxslt package to 1.1.43 soon.

Data as of 5 Nov 2026, 14:32 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.17.8
Patch
Available – fixed in 1.1.43
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Debian debian/libxslt package to 1.1.43.

Affected software

ProductAffectedFixed in
Debiandebian/libxsltpkg:deb/debian/libxsltOther threatsAffected
  • <1.1.43
Fixed in
  • 1.1.43

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libxslt packages for Red Hat Enterprise Linux 8.6 to address these vulnerabilities. Users should apply the official security update as described in the Red Hat advisory (RHSA-2025:3625) to remediate the issues. Detailed update instructions are available at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor.

Description

Two use-after-free vulnerabilities have been identified in the libxslt library, which is used for transforming XML files using XSLT stylesheets. These vulnerabilities are tracked as CVE-2024-55549 and CVE-2025-24855. Red Hat has issued an important security update for libxslt in Red Hat Enterprise Linux 8.6 to address these issues. The vulnerabilities could potentially lead to memory corruption or other impacts related to use-after-free conditions.

References

Community reviews

Loading reviews…