Skip to main content
CVE-2024-34397VulnerabilityPublished Updated

Red Hat Security Advisory: mingw-glib2 security update

Affects Red Hat mingw-glib2Source GCVE Database

0
Compare
Authoritative record:CVE-2024-34397· Medium 5.2

Not known to be exploited · CVSS 5.2 Medium : upgrade the Debian debian/glib package to 2.80.1 or 2.78.5 when convenient.

Data as of 5 Nov 2026, 13:33 UTC

CVSS 3.1 base score
5.2Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.80.1, 2.78.5
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Debian debian/glib package to 2.80.1 or 2.78.5.

Affected software

ProductAffectedFixed in
Debiandebian/glibpkg:deb/debian/glibOther threatsAffected
  • <2.78.5
  • >=2.79.0 <2.80.1
Fixed in
  • 2.78.5
  • 2.80.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated mingw-glib2 packages for Red Hat Enterprise Linux 9 and its Extended Update Support versions. Users should apply these official updates as described in the Red Hat advisory and referenced article (https://access.redhat.com/articles/11258) to remediate the vulnerabilities. Since a fix is available, applying the update is the recommended mitigation.

Description

A security update for mingw-glib2 in Red Hat Enterprise Linux 9 addresses signal subscription vulnerabilities identified as CVE-2024-34397. GLib is a core library for C applications, providing essential system components used in GNOME and other software. The update fixes these vulnerabilities to improve security. The advisory rates the impact as moderate and provides updated packages for affected Red Hat CodeReady Linux Builder variants.

References

Community reviews

Loading reviews…