Skip to main content
CVE-2026-53938VulnerabilityPublished Updated

Red Hat Security Advisory: mod_auth_openidc:2.3 security update

Affects Red Hat mod_auth_openidc:2.3Source GCVE Database

0
Compare
Authoritative record:CVE-2026-53938· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade Red Hat cjose to 0.6.2.5 soon.

Data as of 30 Oct 2026, 03:01 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.6.2.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade cjose and openidc/cjose to 0.6.2.5.

Affected software

ProductAffectedFixed in
OpenIDCcjoseAffected
  • <0.6.2.5
Fixed in
  • 0.6.2.5
GitHubopenidc/cjosepkg:github/openidc/cjoseOther threatsAffected
  • <0.6.2.5
Fixed in
  • 0.6.2.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update that fixes this vulnerability in cjose and mod_auth_openidc packages for Red Hat Enterprise Linux 8.6. Users should apply the update as described in the Red Hat advisory (RHSA-2026:77371) to remediate the issue. No additional mitigation steps are indicated.

Description

A heap buffer overflow vulnerability exists in the cjose library used by the mod_auth_openidc module for Apache HTTP Server. This flaw occurs during AES Key Wrap decryption and can lead to a denial of service condition. The issue is tracked as CVE-2026-53938 and affects Red Hat Enterprise Linux 8.6 variants. Red Hat has issued a security update to address this vulnerability.

References

Community reviews

Loading reviews…