Skip to main content
CVE-2024-24814VulnerabilityPublished Updated

SUSE · security update for mod_auth_openidc

Affects SUSESource GCVE Database

0

Not known to be exploited : upgrade to 2.4.9.4 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.9.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/mod_auth_openidc to 2.4.9.4.

Affected software

ProductAffectedFixed in
Red Hatredhat/mod_auth_openidcpkg:rpm/redhat/mod_auth_openidcOther threatsAffected
  • <2.4.9.4 >=2.3
Fixed in
  • 2.4.9.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for mod_auth_openidc to address this vulnerability. Users of affected Red Hat Enterprise Linux 8 versions should apply the update to mod_auth_openidc version 2.4.9.4 or later as provided in Red Hat Advisory RHSA-2024:5289. Detailed update instructions are available at https://access.redhat.com/articles/11258. No additional mitigation steps are required beyond applying the official patch.

Description

A denial of service (DoS) vulnerability (CVE-2024-24814) exists in the mod_auth_openidc Apache HTTP Server module when using the OIDCSessionType client-cookie configuration and manipulating cookies. This vulnerability affects Red Hat Enterprise Linux 8 versions of mod_auth_openidc. Red Hat has released an update to address this issue, which has been rated with moderate security impact. The vulnerability allows an attacker to cause a DoS condition by manipulating cookies. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…