Skip to main content
CVE-2024-36387VulnerabilityPublished Updated

Red Hat Security Advisory: mod_http2 security update

Affects Red HatSource GCVE Database

0

Not known to be exploited · fixed in 9.8.1 : update Red Hat when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Low

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.7% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8.1, 9.6.1, 9.4.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/mod_http2 to 9.8.1, 9.6.1 or 9.4.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/mod_http2pkg:rpm/redhat/mod_http2Other threatsAffected
  • >=9.4 <9.4.1
  • >=9.6 <9.6.1
  • >=9.8 <9.8.1
Fixed in
  • 9.4.1
  • 9.6.1
  • 9.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released security updates that address this vulnerability. Users should apply the official patches provided by Red Hat to affected versions of Red Hat Enterprise Linux 9. For detailed update instructions, refer to Red Hat's advisory and article at https://access.redhat.com/articles/11258. No additional mitigation actions are specified or required beyond applying the update.

Description

A low severity denial of service (DoS) vulnerability (CVE-2024-36387) exists in the mod_http2 Apache httpd module used in Red Hat Enterprise Linux 9. The issue is caused by a null pointer dereference triggered by websocket traffic over HTTP/2. Red Hat has released security updates to address this flaw.

References

Community reviews

Loading reviews…