Skip to main content
CVE-2025-23166VulnerabilityPublished Updated

Red Hat Security Advisory: nodejs:20 security update

Affects Red HatSource GCVE Database

0

Not known to be exploited : upgrade to 20.19.2 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 20.19.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Red Hat to 20.19.2.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=20.0.0 <20.19.2
Fixed in
  • 20.19.2

AI-suggested

Red Hat has released updated Node.js 20 packages for Red Hat Enterprise Linux 9.4 Extended Update Support to address this vulnerability. Users should apply the security update as described in the Red Hat advisory RHSA-2025:8902 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated or required beyond applying the official update.

Description

A security update for Node.js 20 on Red Hat Enterprise Linux 9.4 addresses a vulnerability identified as CVE-2025-23166. The issue involves a remote crash triggered via the SignTraits::DeriveBits() function in Node.js. Red Hat has rated this update as important and has released updated packages to remediate the vulnerability. The advisory applies to multiple architectures and extended update support versions of Red Hat Enterprise Linux 9.4. No CVSS score is provided, but the severity is assessed as high by Red Hat. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…